You must rebuild it with bitcode enabled (Xcode setting ENABLE_BITCODE)

出现场景:

正常调试是没有问题的,但是在Archive的时候,报出了这个错误。

问题详情:

(null): URGENT: all bitcode will be dropped because ‘xxxx’ was built without bitcode. You must rebuild it with bitcode enabled (Xcode settingENABLE_BITCODE), obtain an updated library from the vendor, or disable bitcode for this target. Note: This will be an error in the future.
问题分析:


从上述的错误中应该可以看出,这是因为一个第三方的库不兼容,我的工程中开启了 ENABLE_BITCODE (应该是升级之后自动转换的),而这个第三方的库在编译的时候没有 enable bitcode,所以导致上诉问题.

解决方法:

应该是有两种吧,一种就是换成 enable bitcode 的第三方库,再有一种就是将工程的 ENABLE_BITCODE 设置为 false 就可以了。

因为我这里不太方便换库,所以,就把工程的设置给改了一下。

具体操作方法如下:

操作方法

上面解决方法是把工程的设置给改了,但是改了之后有什么影响现在还没有发现。如果以后发现了会更新本文。


转载请注明出处http://blog.csdn.net/chen_gp_x

展开阅读全文

没有更多推荐了,返回首页

©️2019 CSDN 皮肤主题: 撸撸猫 设计师: 设计师小姐姐
应支付0元
点击重新获取
扫码支付

支付成功即可阅读